upgrade questions

sstgerma
Posts: 29
Joined: Wed Oct 04, 2017 11:18 am

upgrade questions

Postby sstgerma » Thu Nov 02, 2017 12:39 am

I was excited to see the 0.9.5 upgrade release. I downloaded 0.9.5 then replaced the contents of my project's lib and plugins directories that had 0.9.4. The hotspot editor seems great! I was wondering if I need to change anything else. I noticed that since I upgraded my panorama's are loading more slowly (I am wondering if this has to do with new multi-resolution feature). Also am finding that my gyro button is not showing up consistently and when this happens I cannot pan in the image. I am guessing it is something I have down but wanted to verify since I am on a deadline. Thanks!

User avatar
rroux
ForgeJS Team
Posts: 166
Joined: Wed Oct 26, 2016 12:19 pm

Re: upgrade questions

Postby rroux » Thu Nov 02, 2017 3:52 pm

Hi sstgerma,

I noticed that since I upgraded my panorama's are loading more slowly


That is weird. If you do not use multiresolution panos, this have no impact on your project.
I know that we have a pano preview feature now. Maybe this causes a delay ?
I'll investigate but I have no clear answer right now!

Also am finding that my gyro button is not showing up consistently and when this happens I cannot pan in the image


Can you open you console and tell me if you have any error in your logs ? This sounds like a crash.
Can you also tell me your browser name and OS?


Have a nice day!
- Raphaël

sstgerma
Posts: 29
Joined: Wed Oct 04, 2017 11:18 am

Re: upgrade questions

Postby sstgerma » Fri Nov 03, 2017 12:43 am

Thanks for your help on this. I am using Google Chrome Version 62.0.3202.75 (Official Build) (64-bit) on Windows 10. I had trouble attaching the errors I am seeing in the console in a docx (getting invalid file extension).

Saw popup in Chrome saying "Rats! WebGL hit a snag" Ignore Reload with this in the developer console:

THREE.WebGLRenderer 86
forge.min.js:4 [ForgeJS] FORGE.RenderDisplay: missing api navigator.getVRDisplays (@888.64ms)
fa @ forge.min.js:4
forge.min.js:4 [ForgeJS] FORGE.PluginEngine: Device compatibility check for plugin org.forgejs.webvrbutton failed! (@1008.23ms)
fa @ forge.min.js:4
forge.min.js:4 [ForgeJS] FORGE.PluginEngine: [object Object] (@1008.30ms)
fa @ forge.min.js:4
forge.min.js:4 Object
fa @ forge.min.js:4
forge.min.js:4 [ForgeJS] FORGE.PluginEngine: Device compatibility check for plugin org.forgejs.gyroscopebutton failed! (@1018.81ms)
fa @ forge.min.js:4
forge.min.js:4 [ForgeJS] FORGE.PluginEngine: [object Object] (@1018.90ms)
fa @ forge.min.js:4
forge.min.js:4 Object
fa @ forge.min.js:4
3three.r86.custom.min.js:86 THREE.WebGLProgram: gl.getProgramInfoLog()

sstgerma
Posts: 29
Joined: Wed Oct 04, 2017 11:18 am

Re: upgrade questions

Postby sstgerma » Fri Nov 03, 2017 12:10 pm

I am also seeing a series of this error:

Slow network is detected. Fallback font will be used while loading: https://fonts.gstatic.com/s/mavenpro/v1 ... Nrsc.woff2

Saw it on my home laptop but wanted to rule out my wifi connection - I am seeing same when at work so thought to mention. Images loaded quickly on previous version.

Looking forward to your feedback.

User avatar
bbaudel
ForgeJS Team
Posts: 45
Joined: Wed Oct 26, 2016 9:20 am

Re: upgrade questions

Postby bbaudel » Fri Nov 03, 2017 4:12 pm

Seems to be a Chrome DevTools issue : https://twitter.com/ChromeDevTools/stat ... 4826966016
Is it better without the ChromeDevTools opened or into an other browser ?
Thanks,
Benjamin

sstgerma
Posts: 29
Joined: Wed Oct 04, 2017 11:18 am

Re: upgrade questions

Postby sstgerma » Fri Nov 03, 2017 4:42 pm

Unfortunately the error is not specific to Chrome. I am seeing same frozen/non-responsive behavior in the other browsers too.

sstgerma
Posts: 29
Joined: Wed Oct 04, 2017 11:18 am

Re: upgrade questions

Postby sstgerma » Fri Nov 03, 2017 9:57 pm

I just tried removing the plugins I had installed (Editor, Toolbox, WebVR and GyroButton) and now the panoramas load quickly and I can pan and move in them again ... phew! They worked fine with 0.9.4. Is there anything that needs to change for them in config.json for 0.9.5?

User avatar
bbaudel
ForgeJS Team
Posts: 45
Joined: Wed Oct 26, 2016 9:20 am

Re: upgrade questions

Postby bbaudel » Mon Nov 06, 2017 9:07 pm

Is it possible to send us your json configuration file with plugins to have a test on our side ?
Best Regards, Benjamin

sstgerma
Posts: 29
Joined: Wed Oct 04, 2017 11:18 am

Re: upgrade questions

Postby sstgerma » Mon Nov 06, 2017 9:17 pm

I would be happy to share my config.json file. However when I try to attach it I am getting, "Error
Invalid file extension: config.json".

sstgerma
Posts: 29
Joined: Wed Oct 04, 2017 11:18 am

Re: upgrade questions

Postby sstgerma » Tue Nov 07, 2017 2:28 am

I am not sure how to proceed. In really need to use the new Editor plugin. However when I have it enabled with this in my config.json (excerpt below) the panorama freezes and I see this in browser developer tool - This happens in Chrome, Firefox and IE. When I remove the plugin the page is responsive again. I have about 13 panoramas in my project and it worked on a couple of pages but very inconsistently. I really need to add a lot of hotspots quickly and this is blocking. Should I revert back to 0.9.4? Please let me know.

THREE.WebGLRenderer 86
forge.min.js:4 [ForgeJS] FORGE.RenderDisplay: missing api navigator.getVRDisplays (@1057.48ms)
fa @ forge.min.js:4
forge.min.js:297 Uncaught TypeError: this.c[b].pi is not a function
at ra.g.Cm (forge.min.js:297)
at ForgePlugins.Editor.dump (:8080/assets/plugins/Editor/build/forge.editor.min.js:1)
at EditorHistory.add (:8080/assets/plugins/Editor/build/forge.editor.min.js:1)
at ForgePlugins.Editor.boot (:8080/assets/plugins/Editor/build/forge.editor.min.js:1)
at ze (forge.min.js:549)
at we.g.po (forge.min.js:548)
at Da.g.Wj (forge.min.js:41)
at Da.g.Vb (forge.min.js:41)
at r.g.D (forge.min.js:39)
at Be.g.nk (forge.min.js:563)
:8080/assets/plugins/Editor/build/forge.editor.min.js:1 Uncaught TypeError: Cannot read property 'update' of null
at ForgePlugins.Editor.update (:8080/assets/plugins/Editor/build/forge.editor.min.js:1)
at we.g.update (forge.min.js:549)
at qa.g.update (forge.min.js:573)
at u.g.update (forge.min.js:17)
at ma.undefined.c.requestAnimationFrame.timeout.j.config.update.f (forge.min.js:628)

"plugins":
{
"prefix": "/assets/plugins/",

"engines":
[
{
"uid": "org.forgejs.editor",
"url": "Editor/"
}
],

"instances":
[
{
"uid": "editor",
"engine": "org.forgejs.editor"
}
]
}

Who is online

Users browsing this forum: RidgeveP and 2 guests