WebVr plugin not displaying

btrajano
Posts: 6
Joined: Mon Aug 07, 2017 1:41 pm

WebVr plugin not displaying

Postby btrajano » Wed Aug 23, 2017 5:25 pm

Me again :)

So I i added the plugin for WebVr in my config.jason file but i can not see the button when I open the page in my phone. Can you tell me if i need to do anything else ?

"plugins":
{
"prefix": "../../plugins/",

"engines":
[
{
"uid": "org.forgejs.gyroscopebutton",
"url": "GyroscopeButton/"
},

{
"uid": "org.forgejs.webvrbutton",
"url": "WebVRButton/"
}
],

"instances":
[

{
"uid": "gyrobutton",
"engine": "org.forgejs.gyroscopebutton",

"options":
{
"bottom": 10,
"left": 10
}
}

{
"uid": "webvrbutton",
"engine": "org.forgejs.webvrbutton",

"options":
{
"bottom": 10,
"right": 10
}
}
]

This what i have in my config file. Do in need to do anything in the index.html file ?
Thanks

User avatar
aberthet
ForgeJS Team
Posts: 19
Joined: Tue Dec 13, 2016 2:53 pm

Re: WebVr plugin not displaying

Postby aberthet » Fri Aug 25, 2017 7:20 am

Hi,

Which phone are you using ? If WebVR is not available on your phone, the plugin won't get displayed. We are working on integrating a WebVR polyfill, to obtain a behavior like on Google Cardboard.

From your other posts, I think you're using an iPhone, so it is why the plugin doesn't show, as iOS is not WebVR ready yet (but seems in the roadmap of Apple, let's see when the iPhone 8 will be unveiled ;) )

abishek
Posts: 2
Joined: Mon Oct 16, 2017 9:13 am

Re: WebVr plugin not displaying

Postby abishek » Mon Oct 16, 2017 9:16 am

I used the webvr-polyfill branch of forgejs and the polyfill from that repo. I can see the webvr-button but when I click on it, it just asks me to buy a cardboard VR box. Even if I rotate the phone, it doesn't seem to load the media in stereo. any suggestions on what I could be getting wrong?

User avatar
aberthet
ForgeJS Team
Posts: 19
Joined: Tue Dec 13, 2016 2:53 pm

Re: WebVr plugin not displaying

Postby aberthet » Mon Oct 16, 2017 12:34 pm

Hi abishek,

Unfortunately, the webvr-polyfill branch is not stable at all, and shouldn't be used. The polyfill shouldn't be working at all, so it isn't surprising. We're truly sorry about that, we want to resolve this issue but we are currently lacking resources and time to do so. Hopefully it will be good soon, or no need for a polyfill soon.

abishek
Posts: 2
Joined: Mon Oct 16, 2017 9:13 am

Re: WebVr plugin not displaying

Postby abishek » Mon Oct 16, 2017 4:58 pm

hi aberthet,

Thanks for clarifying that part :) I might have created a few more posts on the polyfill part not working as expected! I'll wait around and see who resolves it first (the browsers or forgejs/webvr)! I wish I could understand the polyfill parts a little more so I can try to help.

Thanks anyway.

Who is online

Users browsing this forum: No registered users and 2 guests